35

A late answer (and a shameless plug), but I have been working on math companion to Linux Libertine fonts, which got more attention recently (thanks to support from TUG) and it is starting to take shape. The character coverage is still a bit limited and there may be bugs in the existing ones, but testing and bug reports are appreciated. I’m currently ...


23

Let's walk through all cases: Au{f}lage (or Auf{l}age or Auf{}lage}) (I) This does not break up the ligature at all in luatex, and in fact (contrary to widespread belief) has never reliably done so even in pre-luatex engines (eg. pdftex, tex). Auf"-lage (II) This shortcut from German babel inserts a hyphenation point allowing hyphenation in the ...


21

The height of numbers in some fonts tend to be optimised for appearance in normal text which means that they usually are slightly smaller than the height of the upper case glyphs. This however becomes an issue when these glyphs are surrounded by upper case. Numbers are not the only glyphs that follow that rule, the dash is also on of these glyphs that can ...


17

To provide a more current answer to this, there is now Libertinus, a fork of Linux Libertine with bug fixes and pretty nice math support (check out this example document). \documentclass[varwidth,border=1mm]{standalone} \usepackage[ math-style=ISO, bold-style=ISO, partial=upright, nabla=upright ]{unicode-math} \setmainfont{Libertinus Serif}...


17

I created a few preliminary config files for microtype and libertine for usage with pdflatex. They're publicly available from my Bitbucket site. bitbucket.org/cgnieder/microtype-config They're all named mt-<fontname>.cfg and if placed in a suitable place in the local TEXMF tree will be picked up automatically by microtype. This files are far from ...


17

If you add \typeout{\the\font} \typeout{\the\fontdimen2\font} %space \typeout{\the\fontdimen3\font} %stretch \typeout{\the\fontdimen4\font} % shrink \typeout{\the\fontdimen7\font} % punct after \begin{document} then you will find pdftex \OT1/LinuxLibertineT-TLF/m/n/12 3.0pt 1.5pt 0.99959pt 0.5004pt xetex \TU/LinLibertine(0)/m/n/12 3.0pt 1.5pt 1.0pt ...


13

There is no simple answer to this. Or, rather, you already know the simple answer. In general, I would recommend \usepackage[T1]{fontenc} unless you know you need something different. In general, this will give good results which will be better than the alternatives in most cases. This is because the T1 encoding will get you everything the default OT1 ...


12

If XeLaTeX is the only format that satisfies your typesetting needs -- in particular, if you can't use LuaLaTeX -- you have two options for suppressing the tt ligature while not also turning off all "common" ligatures entirely: Insert what TeX calls an implicit kern (of zero width) between the two t characters: rot\kern0pt ten % note: no space between "\...


11

If you just want to disable the tt ligature without disabling the others and don't want to manually add a kern each time, you can use the xetex charclass mechanism. I don't seem to have the font so I disabled ff in arial instead, also I inserted a 10pt kern rather than 0pt, to make it more obvious. Note in the second line ff is separated but the fi ...


11

This is perhaps one of the cases where the new primitive \pdfinterwordspaceon can be useful. If I run \documentclass{article} \pdfinterwordspaceon \usepackage{libertine} \usepackage{lipsum} \setlipsumdefault{1} \begin{document} \lipsum \end{document} and save to text from Adobe Reader, the spaces show.


11

It's a bug in the Type1 version of the Biolinum font; the Type1 font used by the combination slanted/boldface is LinBiolinumTBO.pfb and this is what fontforge shows for the character “L” where the corner is quite evident. The same character in the OpenType font Important update Bob Tennent has submitted an updated version of the fonts on CTAN. After ...


10

Load T1 before OT1, undeclare \l as an OT1 command and declare its default to be T1: \documentclass{article} \usepackage[T1,OT1]{fontenc} \usepackage{libertine} \UndeclareTextCommand{\l}{OT1} \DeclareTextSymbolDefault{\l}{T1} \title{This is Quantifiably finally ligatured text} \begin{document} \maketitle I need the character \l{} too though. \end{...


9

XeTeX simply doesn't support the \pdfglyphtounicode primitive, so this route is not available. To understand why, remember that pdfTeX is 8-bit while XeTeX is natively UTF-8. AS such, it's perfectly reasonable for XeTeX to expect fonts to be 'properly' constructed to have glyphs in the appropriately-named slots and therefore to work correctly in the PDF ...


9

Here’s an answer for the current libertine version of 2014/11/25, since lockstep’s answer doesn’t work anymore with this current version (probably due to the changes in maintainer and conception since 2011). Generally, Linux Libertine’s digits are either proportional (different widths) or tabular (same widths), and either oldstyle (different heights) or ...


9

You can consider newtxmath with the libertine option. The math fonts used are not OpenType, so no unicode-math, but the result is pretty good. The order of packages is important. \documentclass{article} \usepackage{amsmath} \usepackage[libertine]{newtxmath} \usepackage[no-math]{fontspec} \usepackage{mleftright} \setmainfont{Linux Libertine O} \pagestyle{...


9

This seems to work: \documentclass[12pt]{memoir} \usepackage[T1]{fontenc} \usepackage[oldstyle]{libertine} \makeatletter \renewcommand*\libertine@figurestyle{LF} \makeatother \usepackage[libertine]{newtxmath} \makeatletter \renewcommand*\libertine@figurestyle{OsF} \makeatother \begin{document} \section{foo 123 bar} Text figures: 0123456789 \textbf{...


9

There are a couple of possible answers. One is to use {} to encase the second letter of the (not to be made into a) ligature pair, in this case: Auf{l}age, Suf{f}rage. OOPS, I JUST NOTICED: this solution doesn't work under LuaLatex. Instead, try the explicit correction for italics, Auf\/lage. A second possible approach is the selnolig (selective no ...


9

with Alegreya small caps are a family and not a shape and so the default settings of microtype don't affect them. You must activate tracking yourself: \documentclass{article} \usepackage[tracking = true, letterspace = 500]{microtype} \usepackage{Alegreya} % <- tracking does not work with small caps \DeclareMicrotypeSet*[tracking]{alegreyasc} { font = ...


8

The right order to load those packages is amsthm, newtxmath, mathspec \usepackage{amsthm} \usepackage[libertine]{newtxmath} \usepackage{mathspec} You don't need to load amsmath since it is already loaded by newtxmath. That's also the reason why mathspec complains when you load newtxmath after it. Moreover, note that both amsthm and newtxmath define the \...


8

After discussing this on HarfBuzz mailing list, it appears to be a bug in the latest version of Linux Libertine. The proper action here is to notify the font developers and point them to that discussion, a short term “fix” is to downgrade to version 5.1.3 of the font. Based on that, I believe it is a LuaTeX font loader bug to apply the kerning here, as it ...


8

Activate the option Ligatures = NoCommon. See the fontspec manual under 10.1. \documentclass{article} \usepackage{fontspec} \setmainfont[Ligatures={TeX,NoCommon}]{Linux Libertine O} \begin{document} Auflage \end{document} To turn off ligatures for "single cases" (if I understand you correctly when you use that phrase), you can add the Ligatures = NoCommon ...


8

The following is really just a lengthy follow-up comment on some of the issues discussed in the earlier answers that address the OP's questions. Because this comment is too long to fit in an ordinary-comment space, I'm posting it as a separate answer. I believe the OP raises two separate issues: How to break up the fl-ligature in a word such as "Auflage" -...


8

You can simply remove the option math when loading mathspec. MWE \documentclass[11pt]{article} \usepackage{mathspec} \setprimaryfont{Linux Libertine O} \begin{document} 1 $1$ $\mathrm{1}$ $\text{1}$ \end{document} Output Loading mathspec with the math option forces mathspec to load fontspec without the no-math option. And the fontspec manual states: ...


8

The default pandoc template has 100 \usepackage{amssymb,amsmath} 101 \usepackage{ifxetex,ifluatex} 102 \ifnum 0\ifxetex 1\fi\ifluatex 1\fi=0 % if pdftex 103 \usepackage[$if(fontenc)$$fontenc$$else$T1$endif$]{fontenc} 104 \usepackage[utf8]{inputenc} 105 \usepackage{textcomp} % provide euro and other symbols 106 \else % if luatex or xetex 107 $if(...


7

The issue with luatex crashing has been fixed in LuaTeX SVN. See http://tracker.luatex.org/view.php?id=787 It still won't help with font loading though.


7

It turns out that when compiling with XeLaTeX (but not with LuaLaTeX), fontspec doesn't load the bold fonts when it calls system fonts, but rather the semibold fonts, even though the .log file seems to state that the regular bold (B) and bold italic (BI) fonts have been loaded, rather than the semibold (Z) and semibold italic (ZI). \documentclass{article} \...


7

Font feature FakeStrech might help: \documentclass[parskip=full]{scrartcl} \usepackage{libertine} \begin{document} This is a text that is a little to long for this line. {\addfontfeatures{Scale=0.5} This is a text that is a little to long for this line.} {\addfontfeatures{FakeStretch=.5} This is a text that is a little to long for this line.} \end{...


7

The family name you should use is not libertine. Just change \fontfamily{pbk} into \rmfamily (this is because, by default, scrbook applies \sffamily to chapter titles). \documentclass{scrreprt} \usepackage{lipsum} \usepackage{libertine} \usepackage{tabularx} \usepackage{xcolor,fix-cm} \definecolor{numbercolor}{RGB}{150,20,0} \makeatletter \renewcommand\...


7

Try \DeclareFontSubstitution{T3}{ptm}{m}{n} after \usepackage{tipa}


Only top voted, non community-wiki answers of a minimum length are eligible