5

style=ieee implements verbose numeric citations of the form [1], [2], [3] if you want more compact citations you need to replace style=ieee with bibstyle=ieee,citestyle=numeric, to obtain [1, 2, 3] or even bibstyle=ieee,citestyle=numeric-comp, to obtain [1-3] Naturally you must use one \cite command for those citations \cite{sigfridsson,...


5

You could change the \cite command or create a new command that automatically adds "ref." or "refs.": \documentclass{article} \usepackage{hyperref,cleveref} \usepackage[backend=biber,sorting=none,citestyle=numeric-comp]{biblatex} \addbibresource{biblatex-examples.bib} \NewBibliographyString{refname} \NewBibliographyString{refsname} \...


4

Based on Footfullcitetext and beamer: incremental numbering you could work around the problem like this: \documentclass{beamer} %\usepackage{pgf} %\usepackage{xcolor} \usepackage[utf8]{inputenc} % Citation \usepackage[style=science]{...


4

If this is about natbib you can't have multi-cites with postnotes for each citation, you have to work around that limitation with \citetext and \citealp. \citetext{\citealp[see][Chap.~3]{sigfridsson}; \citealp{worman}} I.e. \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage[round,...


4

A refsection could help. In the following example your own references will be sorted as they appear in the bib file, if you want another order, see Ulrike Fischer's comment. \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[USenglish]{babel} \usepackage{filecontents} \usepackage[ defernumbers=true, backref=true, ...


4

If you add the sort option to natbib \usepackage[sort,comma,authoryear,round]{natbib} then it sorts first by author name and then by year. You seem to want to sort by year first and then author name. I don't believe natbib has support for that. Edit: It's pretty easy to modify a copy of plainnat.bst to sort first by year than by name. This doesn't ...


4

The user guide of the natbib package (cf. p. 9, lower half) expressly discourages the use of multiple arguments with \citet unless the pieces being cited have the same author(s). (The situation is different for \citep.) Thus, instead of writing ... \citet{Roussy2005,Roussy2005a,Teixeira2006} ... you should write ... \citet{Roussy2005,Roussy2005a} and \...


4

Well, there were some things to be done to achieve what you want. The lines of code that @samcarter mentioned seemed to try to override the underlying mechanism for labeldate. I assumed here you wanted to do so only for online entries, not letting urldate take the place of labeldate. That was done by commenting the mentioned lines of code, and redefining the ...


4

You can use biber --tool duplicates.bib This will create a duplicates-bibertool.bib without duplicates.


3

You can suppress the movement of punctuation marks with the nomove option: \documentclass[10pt]{article} \usepackage[paperheight=29.7cm,paperwidth=21cm,tmargin=25mm,bmargin=25mm,lmargin=25mm,rmargin=25mm,heightrounded]{geometry} \usepackage{graphicx,siunitx,pdflscape} \usepackage{amsmath,amssymb,graphicx,wasysym,paralist,textcomp} \usepackage[english]{babel}...


3

Using style=apa6 should solve your problem (you will need the biblatex-apa6 package). The apa style currently takes the 7th version of APA style into account, which has changed in-line citations of works with multiple authors.


2

The quickest but dirty way would be to redefine the \NAT@sep macro: \makeatletter\def\NAT@sep{ and}\makeatother Or you could use the \bibpunct macro (from the natbib.sty source): Use \bibpunct with 6 mandatory arguments: 1. opening bracket for citation 2. closing bracket 3. citation separator (for multiple citations in one \cite) 4....


2

An answer with biber (I changed bibtex to biber and added '\nocite{*}' befor last printbibliography. See the comments): \documentclass{article} \usepackage[backend=biber, style=numeric, defernumbers]{biblatex} %<- changed "bibtex" to "biber" \usepackage{lipsum} \addbibresource{./latexfiles/ref.bib} \DeclareBibliographyCategory{skipbibliography} \...


2

biblatex's default style style=numeric shows each cited item individually. If you want to compress the citations to "[1-5]", you need to load style=numeric-comp See also §3.3.1 Citation Styles of the biblatex documentation and the style example for numeric and numeric-comp.


2

With biblatex you'll want to use the multicite commands, see §3.8.3 Qualified Citation Lists of the biblatex documentation. \cites[25\psq]{sigfridsson}[55\psq]{worman}[26\psq]{geer} In full \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{csquotes} \usepackage[style=authoryear, backend=...


2

If you use the natbib citation management package, you could employ three \citealt directives encased in a common ( ... ) set of parentheses. E.g., something like the following: If you want commas between the authors' names and the years, simply use \citealp instead of \citealt. \RequirePackage{filecontents} \begin{filecontents}{mybib.bib} @misc{cit01,...


2

The tricky bit is when the \footcite is in a paragraph which gets split across two pages. Both halves think they are on the first page. The ifoddpage package can be used to handle that, but it takes two runs. \documentclass{article} \usepackage[style=authoryear]{biblatex} \addbibresource{Literature.bib} \usepackage{xparse}% for multiple optional ...


2

The error message \bibstyle{ApJ : } I'm skipping whatever remains of this command tells you that the bibliography style is unknown to overleaf. You need to add a file apj.bst to your project, that means add it into the same directory you have your TeX file. You can for example find a link to apj.bst on the website of aastex in section 2.13.2 ...


2

I see two easy ways of dealing with this: Break up the composite entry into two regular ones and cite them both - like "according to Gibbs et al [1] (as reproduced in [2])." Manually edit the .bbl file generated by bibtex. Do this at the very end, when you are done with all other changes to your document. Then, replace the \bibliography{myreferences} at ...


2

The package mcite (like most other citation or bibliography packages) is incompatible with biblatex, I'm afraid. You can't load both packages together in the same document, biblatex will issue an error about it sooner or later (even if you ignore the error, there is zero chance that biblatex will be able to make use of mcite's interface). biblatex offers its ...


2

Try \documentclass{revtex4} \makeatletter \let\c@affil\relax \makeatother \usepackage{authblk} \title{Article Title} [...]


2

An alternative to @samcarter's since I done it before see the answer: \documentclass{beamer} \usepackage{pgf} \usepackage{xcolor} \usepackage[utf8]{inputenc} % Citation \usepackage[backend=bibtex, style=science]{biblatex} \usepackage{...


2

Along with placing all citation keys in the argument of a single \cite command, you need to load a suitable citation management package. I suggest you load either the cite package or the natbib package with options numbers and sort&compress. \documentclass{article} % or some other suitable document class \begin{filecontents}[overwrite]{mybib.bib} @...


2

I will assume that you use a software tool -- say, BibTeX -- to create the formatted bibliography. If that's the case, I suggest you employ the natbib citation management package and, specifically, its \citealp macro, to create the desired look of the citation call-outs. If you use the biblatex package (and biber, presumably, as well), I suggest you load it ...


2

Since you're using the natbib citation management package and the ieeetr bibliography style, you should be able to achieve your formatting objective by (a) running \usepackage[numbers,sort&compress,comma]{natbib} in the preamble and (b) grouping two or more cite keys in the argument of \cite: \cite{key1,key2[,...]} A separate comment: The ieeetr ...


2

You cannot nest refsection environments, but you can make subsets of references using keywords, said "AAA" and "BBB", e.g.: @book{horowitz1989art, title={The art of electronics}, author={Horowitz, Paul and Hill, Winfield}, keywords={AAA, whatever}, year={1989}, publisher={Cambridge Univ. Press} } Then, you only need print by ...


2

refsections are always kept completely independent, so you can't easily print only references that were not cited in the previous section in section 1. Note also that with refsections the same work may get a different number in different refsections, so you can't leave out entries in the bibliography anyway as your readers would have no way to identify the ...


2

Try the following. \documentclass{article} \usepackage[notes]{biblatex-chicago} \addbibresource{biblatex-examples.bib} \DefineBibliographyStrings{english}{ thiscite = {at}, } \newtoggle{cbxchic:hadpages} \renewbibmacro*{fullpostnote}{% \global\toggletrue{cbxchic:hadpages}% \iffieldundef{chapter}% {\iffieldundef{pages}% {\global\togglefalse{...


2

In my personal experience, these kinds of citations are quite useless in an actual conference/thesis presentation. However, you might be writing some lecture presentation where these could be more useful. In any case, here is a reminder on the recommandations regarding citations inside of a beamer presentation (see beamer user guide §5.1.2 p 34). ...


2

You need to set the option sorting to none: \usepackage[style=numeric, sorting=none]{biblatex}


Only top voted, non community-wiki answers of a minimum length are eligible