Hot answers tagged

4

Your write-up isn't entirely clear since the code fragment you've posted appears to attempt to load the mutually incompatible cite and natbib packages. However, since you've also set the natbib tag, I will assume that you're really looking for a natbib-based solution. If this assumption is correct, all you need to do is replace \usepackage[super, square, ...


3

To extract the author and the year for a citation, natbib needs a bibliography entry (in the bbl) which starts like this: \bibitem[Ghahramani(2015)]{ghahramani2015probabilistic} The important part is the syntax of the optional argument [Ghahramani(2015)]. natbib scans this and splits it in author and year. With \bibliographystyle{alpha} the entry looks like ...


3

This happens if you compile on the latex + dvips route: With this driver hyperref put the links by default in a box. If you can't switch to a compilation with pdflatex, add the breakurl package: \usepackage{hyperref} \usepackage{breakurl}


2

The user guide of the mnras document class states -- cf. the left-hand column of page 2 -- that all papers that employ the mnras document class should specify the option usenatbib. Let's assume, then, that the first line in the OP's document is \documentclass[usenatbib]{mnras} The mnras document class recommends (but apparently does not require) use of the ...


2

If your bibliography is generated manually with thebibliography and \bibitems you absolutely cannot use biblatex. biblatex uses a completely different systems to produce citations and bibliography entries that is not compatible with thebibliography and \bibitems. For you this is not of much interest, but it may be nice to know that when you use BibTeX with \...


2

The error message Package natbib Error: Bibliography not compatible with author-year citations. has two major causes: Either it can be taken at face value and then says that the bibliography style you used is incompatible with natbib's authoryear citation option or the style you use is in principle compatible with natbib's authoryear citation option, but ...


2

Have a look here. In short, you want to use natbib (which you do) with \bibliographystyle{agsm}, and remove the \setcitestyle{authoryear,round,aysep={}}. \bibliographystyle{agsm} does everything you want :). PS: Try to post a working example. For instance: \documentclass{article} \usepackage{filecontents} \begin{filecontents}{mybibMD.bib} @article{...


1

In cases like this I think it is perfectly fine to give the author names instead of the corporate entity. If you insist on having "World Bank" as author in the citation, the easiest way is to put it into the author field instead of the actual author names. \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \...


1

You wrote: Since the apa6 class automatically sets the style for citations ... This claim isn't quite correct. If you load the apa6 document class without one of the options biblatex, apacite, or natbib, no citation management package is loaded and no bibliography style is chosen. Here's an excerpt from page 10 of the user guide of the apa6 document class (...


1

natbib has a sort option that allows you to sort \citep/\citet calls in the order the entries appear in the bibliography. \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{csquotes} \usepackage[sort]{natbib} \bibliographystyle{plainnat} \begin{filecontents}{\jobname.bib} @book{aardvark, ...


Only top voted, non community-wiki answers of a minimum length are eligible