Hot answers tagged

7

As far as I know, nomencl does not support this out of the bag. Here's a hacky way to do it instead. Basically it is a redefinition of the \nomenclature[]{}{} command, to ignore the sorting argument (i.e. the optional argument in \nomenclature) and to use a counter-based sorting method instead. Whenever \nomenclature is called, the counter @nomcount raises ...


7

The character | is special for MakeIndex, so entries with it are rejected. You could quote it, but nomencl.ist defines the quoting character as %, so the effect is that no quoting character is available at all. On the other hand, the correct syntax for your set notation and the absolute value is \{x \in \mathbb{R}^{n+1} \mid \lvert x\rvert = 1 \} which ...


5

Your default argument [\nomenclature[z#4]{#2}{#3}] has a ] inside (after #4), so that finishes the argument, and the rest is just text that is inserted in the document. Solution: enclose it in braces: [{\nomenclature[z #4]{#2}{#3}}]%


4

A simple solution would be to patch usage of \addxcontentsline instead of \addcontentsline into nomencl.sty: \documentclass{scrreprt} \usepackage[intoc]{nomencl} \makenomenclature \usepackage{xpatch} \xpatchcmd{\thenomenclature}{\addcontentsline}{\addxcontentsline}{}{} \xpatchcmd{\thenomenclature}{\addcontentsline}{\addxcontentsline}{}{} \KOMAoptions{toc=...


3

The nomencl uses makeindex in order to process the generated nomenclatures. That is, you need to the following steps: pdflatex niccolo.tex makeindex niccolo.nlo -s nomencl.ist -o niccolo.nls pdflatex niccolo.tex Depending on the editor, adding the intermediate makeindex steps will vary a lot, and unfortunately I am not familiar with Sublime Text, so I can'...


3

TLDR: It's not a bug but is the result of makeindex requiring a valid page number, as it's designed for creating indexes. Packages such as nomencl (and glossaries etc) have to sort and collate the information that needs to appear in the list of nomenclature/symbols/terms. TeX really isn't designed for that kind of data processing. (The glossaries package ...


3

I suggest you install the Nomenclature package from the community of WinEdt users, WinEdt.org. It will add a Make Nomenclature item to the TeX menu. Here is a direct link for the package. No button is installed in the toolbar. If you want to have one, open the Toolbar.ini file with the Options interface and insert BUTTON="Make_Nomenclature" between lines ...


3

After pulling out the guts of nomencl and replacing them with metal parts, it seems to be alive! Usage: Different from the usual approach, of redefining the \nomgroup macro to add an \ifstrequal to select the header of the items, the modified form introduces a command: \newsymbolclass[<ncols>]{<id>}{<title>} which defines a "Symbol ...


3

You cannot nest optional arguments (that come in catcode-12-brackets) like mandatory arguments (that come in catcode-1-opening braces and catcode-2-closing-braces). Optional arguments are handled as delimited arguments with opening brackets and closing brackets as argument-delimiters. When nesting optional arguments, (La)TeX' delimited argument-mechanism ...


3

Your makindex style has %% ---- for input file ---- keyword "\\nomenclatureentry" quote '%' so you need % not " The package already reads the argument verbatim, so % is not a comment: \documentclass{article} \usepackage{nomencl} \makenomenclature \begin{document} \nomenclature{$n %! $}{factorial of $n$} \[ n! = \prod_{i=1}^n i \] \printnomenclature ...


2

You should fix how you input the nomenclature entries. Here's an example for getting constants before variables: \documentclass{article} \usepackage{nomencl} \makenomenclature \usepackage{ifthen} % The order will be 1. constants, 2. variables % because C comes before V \renewcommand{\nomgroup}[1]{% \ifthenelse{\equal{#1}{V}}{\item[\textbf{Variables}]}{%...


2

The nomencl package defines \printnomenclature like % nomencl.sty, line 156: \def\thenomenclature{% \@ifundefined{chapter}% { \section*{\nomname} \if@intoc\addcontentsline{toc}{section}{\nomname}\fi% }% { \chapter*{\nomname} \if@intoc\addcontentsline{toc}{chapter}{\nomname}\fi% }% \nompreamble \list{}{% \labelwidth\nom@...


2

The ! character is used internally by MakeIndex, so you cannot use it directly. For normal exclamation marks you can quote them with ". This one, as it is a control character, you can rename it to use in the nomenclature: % arara: pdflatex % arara: nomencl % arara: pdflatex \documentclass{memoir} \usepackage{nomencl} \makenomenclature % Copying \! to \...


2

You can have as many entries as you want with the same symbol. \documentclass{article} \usepackage{siunitx} \usepackage{nomencl} \usepackage{xcolor} \definecolor{tudelft-cyan}{RGB}{0,166,214} \sisetup{ inter-unit-product=\ensuremath{{}\cdot{}}, per-mode=symbol } \makenomenclature \ExplSyntaxOn \RenewDocumentCommand\nomgroup{m} { \item[\textbf{\...


2

As @Nicola-Talbot pointed out, | is a special character for makeindex. But it's better to use $\Vert$ in any case. As an aside, I'm a big fan of the paired delimiter setup in the mathtools package: it ensures that you never have unmatched parentheses. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{amsmath} \...


2

The empty pages are inserted because the list of abbreviations and the list of symbols are each treated like a chapter, which are only supposed to start on left hand pages. To avoid this problem, one can temporally change the definition of \cleardoublepage: % !TeX program = txs:///arara % arara: lualatex: { shell: true } % arara: nomencl % arara: ...


2

The error occurs also with the MWE \documentclass{article} \usepackage[english]{babel} \usepackage{babelbib} \usepackage{nomencl} \begin{document} Hello world. \end{document} The reason is that babelbib defines \ifnumber in the same way as KoMa-Script classes (more precisely, the package scrbase) do. In order to avoid troubles when using one of these ...


2

Insert \par before \vspace{\preGroupSkip}: \documentclass{scrreprt} \usepackage{nomencl} \usepackage{ifthen} \usepackage{siunitx} % No extra line space between items %\setlength{\nomitemsep}{-\parsep} % Divide nomenclature into subgroups \newlength\preGroupSkip \setlength{\preGroupSkip}{3.5ex} \newlength\postGroupSkip \setlength{\postGroupSkip}{2.3ex} \...


1

I finally find the solution. I am using TeXstudio. Go to Option--> Configure Texstudio --> Commands In the field of Makeindex write the following: makeindex.exe %.nlo -s nomencl.ist -o %.nls I have no clue what it means. But it works!


1

The nomencl package uses makeindex to sort the entries alphabetically. To make the nomenclature work correctly you must run: pdflatex - To write the \nomenclature commands into the .nlo file makeindex - To read the .nlo file, sort it, and write the to the .nls file pdflatex - To read back the .nls file and write the nomenclature to the .pdf The command ...


1

So I solved the problem. In Sharelatex I had my main.tex file within a folder. Remove this folder (i.e. have main.tex in the root) fixed the problem. I guess it has something to do with tex having problem to find the .nlo file or something similar. Cheers


1

You can put the entire glossary inside a list and adjust the list margins like this: \documentclass{article} \usepackage[acronyms,nonumberlist,nogroupskip,nopostdot,toc]{glossaries} \usepackage{glossary-mcols} \renewcommand{\glsmcols}{2} \setglossarystyle{mcolalttree} \renewcommand{\glossarypreamble}{% \glsfindwidesttoplevelname[\currentglossary] \begin{...


1

Redefine your \nomgroup using \ifthenelse (inspired from the package documentation) instead of \ifstrequal, and insert a \clearpage command before the start of Symbols. You can obviously generalize this to any number of subgroups that you create using this method. MWE: \documentclass{article} \usepackage{nomencl} \makenomenclature \RequirePackage{...


1

Using no packages at all, you could just make a table. Code: \documentclass{amsart} \newcommand\SINGKATAN[3]{#1&\multicolumn{1}{l}{\textit{#2}}&#3\\} \newcommand\LAMBANG[3]{$#1$&\multicolumn{1}{l}{#2}&#3\\} \begin{document} \begin{table} \begin{tabular}{lcl} \multicolumn{3}{c}{{\Large \textbf{DAFTAR SINGKATAN DAN LAMBANG}}}\\~\\ SINGKATAN&...


1

You can try this: # for nomenclature add_cus_dep("nlo", "nls", 0, "nlo2nls"); sub nlo2nls { system("cd buildfolder; makeindex $_[0].nlo -s nomencl.ist -o $_[0].nls -t $_[0].nlg"); } Going back to the source folder is automatic, as the cd is local to that system command. I haven't tested it, but to the best of my knowledge it should work.


1

In your .ist file, replace Unit with \\Unit. In your .tex file, replace the \nomgroup definition with % define and format nomenclature groups \newcommand{\Unit}{Unit} \newcommand{\noUnit}{\gdef\Unit{}} \renewcommand\nomgroup[1]{% \gdef\Unit{Unit}% \Large\sffamily\bfseries \ifstrequal{#1}{A}{Acronyms\noUnit}{% \ifstrequal{#1}{L}{Latin Symbols}{% \...


1

You need to open and close the multicols environment inside the thenomenclature environment, which can be done with the \nompreamble and \nompostamble hooks. \documentclass[11pt, a4paper, twoside]{book} \usepackage[noprefix,norefeq]{nomencl} \usepackage{multicol} \makenomenclature \usepackage{ifthen} \renewcommand{\nomgroup}[1]{% \item[\bfseries \...


Only top voted, non community-wiki answers of a minimum length are eligible