New answers tagged

0

Given the tags I assume you use Overleaf as an editor. The built-in pdf viewer in Overleaf does not show page numbers as part of the viewer interface, however usually the built-in browser viewer does show which page you are viewing. You can select the built-in viewer to be used with the Overleaf menu (click on the top left button labeled Menu), scroll down, ...


4

The main page style is set to fancy via \pagestyle{fancy} Also the headers and footers (in order to set them to suit your needs) are completely cleared via \fancyhf{} You never use \thepage anywhere. Perhaps you're after \fancyfoot[C]{\thepage} as part of your style so that it matches the plain page style (set as the first page of every \chapter).


1

Change \titlepagestyle to empty: \renewcommand\titlepagestyle{empty} Example: \documentclass %[titlepage] {scrartcl} \usepackage{lipsum} \title{Title}\author{Author} \renewcommand\titlepagestyle{empty} \begin{document} \maketitle \lipsum \end{document} This works even if you use class option titlepage. If there is no \maketitle in your document, then ...


2

amsart, like many similar document classes, includes a \thispagestyle command as part of \maketitle which overrides your \pagestyle{empty} on the first page (you should see no page numbers on subsequent pages). Putting \thispagestyle{empty} after \maketitle will override that and give you no page number on the first page as well.


1

The book class uses the plain page style for the first page of the chapter. Here is the definition in book.cls: \newcommand\chapter{\if@openright\cleardoublepage\else\clearpage\fi ----------->> \thispagestyle{plain}% <<----------- \global\@topnum\z@ \@afterindentfalse \secdef\@...


2

With package scrletter you have to redefine \letterpagemark: \renewcommand*\letterpagemark{% \usekomafont{pagenumber}{\pagename~\thepage~of~\letterlastpage}% } Example: \documentclass{scrartcl} \usepackage{scrletter} \renewcommand*\letterpagemark{% \usekomafont{pagenumber}{\pagename~\thepage~of~\letterlastpage}% } \usepackage{xpatch} \xpatchcmd{\...


0

By combining multiple answers (linked in the code), I've found a solution that just uses the internal scrlttr2 parameter, i.e. mostly \pagemark. Also you have one place to define the page number style there. \documentclass[enlargefirstpage=true]{scrlttr2} \usepackage{scrlayer-scrpage} % better page numbers with total number % https://tex.stackexchange.com/a/...


1

The layout of the first letter page is special. The page style of the first letter page is empty. It uses special elements for the address, location, header, footer etc. You have to use variable firstfoot to add content in the footer of the first page. If you redefine \pagemark to get »Page ... of ...«, then you can use \centering\pagemark for firstfoot: \...


2

You can simple (without additional packages) redefine \pagemark to your needs: \renewcommand*\pagemark{% \usekomafont{pagenumber}{\pagename~\thepage~of~\letterlastpage}% } Example: \documentclass{scrlttr2} \usepackage{blindtext}% only for dummy text \renewcommand*\pagemark{% \usekomafont{pagenumber}{\pagename~\thepage~of~\letterlastpage}% } \begin{...


1

The footer on the first page of a letter is empty by default. You will need to define your own first-page footer using the firstfoot variable and set its position from the top of the page with the firstfootvpos variable. Switch the footer on with the firstfoot=true option. The subsequent footers (done with \cfoot from the scrlayer-scrpage package in your ...


1

The scrlttr2 class offers specific commands for modifying headers and footers, through the scrlayer-scrpage package. The mwe below is a starting point. Note that there is no need to use the lastpage package, as the class provides the internal \lastletterpage counter. \documentclass{scrlttr2} \usepackage{scrlayer-scrpage} \cefoot{Page \thepage\ of \...


1

You have to redefine \letterpagemark in the preamble to get the desired result. \documentclass{scrartcl} \usepackage{scrletter} \usepackage{blindtext}% only for dummy text \renewcommand*\letterpagemark{% \usekomafont{pagenumber}{\thepage}} \begin{document} \begin{letter}{Max} \opening{Hello,} \Blindtext \closing{Bye} \end{letter} \end{document} Another ...


1

With the help of tocloft's \cftaddtitleline{〈file〉}{〈kind〉}{〈title〉}{〈page〉} instead of \addcontentsline{〈file〉}{〈kind〉}{〈title〉} \documentclass[12pt,a4paper,oneside,ngerman]{article} \usepackage{babel} \usepackage{fontspec} \setmainfont{Times New Roman} \usepackage{tocloft} \tocloftpagestyle{empty} \usepackage[footnote]{acronym} \begin{document} \...


2

Here's a solution that (a) employs the tocbibind package to simplify the inclusion of the LoF and LoT in the ToC and (b) modifies the behavior of \addcontentsline locally to suppress the display of the associated page numbers. \documentclass[12pt,a4paper,oneside,ngerman]{article} \usepackage{babel} \usepackage{fontspec} \setmainfont{Times New Roman} \...


1

It really would have helped if you had provided an MWE (from \documentclass... to \end{document}) instead of just a snippet. I had to waste time making your code processable. Change the location of where you put the change to page numbers before the appendices environment. % pagenumprob.tex SE 576560 \documentclass{article} \usepackage{appendix} \...


Top 50 recent answers are included