New answers tagged

0

You can add a prefix as follows: \renewcommand{\thefigure}{S\arabic{figure}} \renewcommand{\thetable}{S\arabic{table}} I use that for my supplementary files. So tables and figures look like Figure S1, Figure S2, ..., Table S1, etc. You could wrap that around a macro that you use in place of \part, using \newcommand


3

I guess you want to keep “Première partie” in the title, so here are a couple of hacks. First, the code in babel-french doesn't consider that \thepart is preceded by a space that should be ignored (or removed), so I fix it by (locally) redefining \thepart to \unskip instead of doing nothing. Second, I patch \@part to make it write directly Partie instead ...


0

According to the babel-french package documentation PartNameFull should be set to false to avoid such problems. So just add \frenchsetup{PartNameFull=false} to your preamble. This should solve your issue. Extract of the documentation: PartNameFull=false (true); when true, babel-french numbers the title of \part{} commands as “Première partie”, “...


0

You can patch \@part (defined in book.cls) and remove the insertion of \thepart and the subsequent space (\hspace{1em}): \documentclass{book} \usepackage{etoolbox} \makeatletter \patchcmd{\@part}% <cmd> {\thepart\hspace{1em}}% <search> {}% <replace> {}{}% <success><failure> \makeatother \begin{document} \...


1

You don't have to use the starred version if you want no part label to appear in the toc. With the newlinetospace option, it is needless to use the optional argument to remove a line break in titles: it is automatically converted to a horizontal space in table of contents and headers. \documentclass[12pt,a4paper,oneside]{scrbook} \usepackage[utf8]{inputenc} ...


Top 50 recent answers are included