Hot answers tagged

7

You need to set input-decimal-markers and input-ignore correctly: \documentclass{article} \usepackage{siunitx} \sisetup{input-decimal-markers = ., input-ignore ={,}} \begin{document} \SI{10,000.42}{\metre} \end{document}


5

You need to get rid of the unnecessary and, in fact, destructive mode of encasing the numbers in an S column in curly braces. While you're at it, do get rid of the $ symbols in the S-type columns as well. \documentclass{article} \usepackage{siunitx} % for 'S' column type \usepackage{booktabs} % for well-spaced horizontal rules % Commands to add space ...


4

cause of your problem seems to be use of @{\extracolsep{\fill}} you define three columns, but use only two ... I would not use tabular* table environment, in my opinion, the result is not nice as solution to your problem I put the column headers into p columns with width equal to half the text width in my MWE, I remove all unnecessary code, repair definition ...


4

Here are three more possibilities: Since your table is too tall to fit into the textblock and you specified that you didn't want to chang the margins, I'd suggest the use of longtable. This might especially come in handy if your caption gets longer than a single line or if you decide to add more rows to your table. In the second example, I have allowed ...


4

with siunitx and tabularx (that table is fit into text area): \documentclass[12pt, a4paper]{article} \usepackage[format=hang, font={small,it}, labelfont={bf,it}, labelsep=space]{caption} \captionsetup[table]{labelsep=space,justification=raggedright,singlelinecheck=off} \usepackage{siunitx} \usepackage{booktabs, tabularx} ...


3

The time of loading is certainly intentional. The binary-units option code (for true) is: binary-units / true .code:n = { \AtBeginDocument { \__siunitx_load_binary: } }, which as the code suggests, does basically \AtBeginDocument{\input{siunitx-binary.cfg}} (with a little more work to have the file be loaded as a package). It isn't clear why this is ...


3

I would use \thead for the column heads, instead of two rows. Your S columns were not aligned on the decimal dot, because your numbers were surrounded by pairs of braces, which means they were ordinary data, which had to be centred. I added the caption package to have a more sensible spacing between caption and table. Your strut commands are needless if you ...


2

It is possible, but have to use dcolumn instead of siunitx, below are the modified tags: \documentclass{standalone} \usepackage{pgfplotstable} \usepackage{dcolumn}% \newcolumntype{d}[1]{D{.}{.}{#1}}% \begin{document} \begin{tabular}{d{2,3} d{2,3}} a & b \\ -0.135 & \pgfmathprintnumber{-0.135} \\ 0.1 & \...


2

too long that I can fit to comment: Welcome to TeX.SE! you define 22 column, but use only 8! your table nicely fit into text width (well, after repairing @{\hskip\tabcolsep\extracolsep\fill} to more correct @{\hspace*{\tabcolsep}\extracolsep{\fill}} so I can't figured out what is your problem ... after done small changes to your code, I obtain the ...


1

Building upon Zarko's answer, here is a variant that also aligns the contents of the first column with respect to the \rightarrow. However, I have replaced tabular* with tabular since there is a quite large amount of horizontal white space in the table. I have added some \addlinespace commands to provide more structure to the table. \documentclass{article} \...


1

Here is part of your table. I have used tabularx for automated line breaks in the last column, threeparttablex for the formatting of the tablenotes, added some sisetup options nd removed unnecessary \multicolumn commands as well as empty rows. Adapting the rest of the table is now up to you. \documentclass{article} \usepackage{geometry} \usepackage{...


1

To have something fill to one page using the MWE, perhaps using the \usepackage{fullpage} would be helpful in achieving that goal. \documentclass[12pt, a4paper]{article} \usepackage[format=hang,font={small,it},labelfont={bf,it},labelsep=space]{caption} \captionsetup[table]{labelsep=space,justification=raggedright,singlelinecheck=off} \usepackage{siunitx} ...


1

The problem here really is that your units are very long. TeX doesn't want to do the offending line break in your MWE because it would be a bad one (you would get an Underfull \hbox). In order to get around this, I you could try to make your units shorter. First off, your unit definition is a bit over-complicated. You can just use \DeclareSIUnit{\tco}{{t_{\...


1

As Joseph Wright explains in his comment, siunitx does not attempt to handle this, because human judgement is needed in deciding what the numbers mean and how to round them. If you want to automate this, you will have to use a different tool.


1

I encountered the same issue when using LaTeX (not XeLaTeX): The current version of siunitx (2018-05-27) is incompatible with the current version of FiraSans (2019-06-06). More precisely, using, for instance, “book” as the regular (medium) fontseries and/or using “semibold” as the default bold fontseries confuses siunitx to the extent that numbers that ...


Only top voted, non community-wiki answers of a minimum length are eligible