Hot answers tagged

6

You can use the \noloc command I defined for a similar purpose \newcommand\noloc{% \nobreak \mspace{6mu plus 1mu} {:} \nonscript\mkern-\thinmuskip \mathpunct{} \mspace{2mu} } Full example: \documentclass{article} \usepackage{amsmath} \newcommand\noloc{% \nobreak \mspace{6mu plus 1mu} {:} \nonscript\mkern-\thinmuskip \mathpunct{} \...


4

In addition to fixing the width of the table's footnote material to that of the tabular environment -- an objective that may be achieved easily by employing the machinery of the threeparttable package -- you should also aim to align the numbers in the three data columns on their respective decimal markers. I suggest you employ the dcolumn package's machinery ...


3

With threeparttable and siunitx package: \documentclass{article} \usepackage{siunitx} \usepackage{booktabs, threeparttable} \begin{document} \begin{table}[ht] \centering \sisetup{table-space-text-pre={(}, table-align-text-pre=false, table-space-text-post={$^{***}$}, table-align-text-post=false, input-open-...


3

Here are two versions of your table: \documentclass{article} \usepackage{geometry} \usepackage{booktabs} \usepackage{threeparttable} % for second example \begin{document} \begin{table}[htbp] \caption{AEX, daily, from 01-01-2020} \begin{tabular*}{\textwidth}{@{\extracolsep{\fill}} c c c c} \toprule \textbf{Variable} & \textbf{Model 1} & \textbf{...


3

In all standard implementations of the PlainTeX and LaTeX formats, the character , ("comma") has status math-punct (for "math punctuation") when used in math mode. TeX inserts a bit whitespace after (but not before) objects of type math-punct. To override this setting, one can write \mathord{,} or, more succinctly, just {,}. Syntactically speaking, there ...


3

As @UlrikeFischer pointed in the question comment, there is no boolean \if@mdframed in mdframed package. The following workaround uses the value of TeX count \mdf@envdepth to determine if the code is executed inside mdframed environtment, and patches each of \start@gather, \start@align and \start@multline. Hope that would work for every amsmath multiline ...


3

If you're submitting to an IEEE journal, then you probably shouldn't be messing with the spacing of titles, since the class is designed with its own sizes in mind. That being said, you can use titlesec, but you will need to use its formatting commands for each section yourself. You can't just use one of the package options, which assume you are using the ...


2

EDIT By more testing (even after adding extra double braces), the answer was not correct when: The macro is followed by another similar macro The macro is followed by another operator (+, -, ...) In both cases an extra thin space is added. Original Answer You can use \operatorname in the definition of your macro, instead of spaces \, \; ,... since the ...


2

Unfortunately, \nopagebreak does not override other favorable break-points inserted by other commands, as does the center environment. The regular way to prevent such breaks is with \samepage, but you still need \nopagebreak between paragraphs. So \rule{1cm}{18cm} % Just here to simulate some text/images/... \begin{samepage} Solution: \begin{center} \rule{...


2

tcolorbox documentation (page 30) suggests to use halign=flush center option instead of halign=center. It also redirects to the corresponding explanation in pages 234 to 238 in pgfmanual. \documentclass{article} \usepackage{fontspec} \usepackage{luatex85} \usepackage[most]{tcolorbox} \tcbuselibrary{raster,skins,breakable} \begin{document} \begin{tcolorbox} ...


2

I have the same issue you faced. You can easily solve it by replacing halign=center with before upper*=\centering in the respective box options. \documentclass{article} \usepackage{fontspec} \usepackage{luatex85} \usepackage[most]{tcolorbox} \tcbuselibrary{raster,skins,breakable} \begin{document} \fontsize{50pt}{50pt}\selectfont Here is a 50pt text....


2

You not provide MWE, which reproduce your problem, so it is hard to tell, what is the cause of the your problem. Considering @Bernard comment, your MWE should be something like this: \documentclass{article} \usepackage{booktabs, makecell, tabularx} %---------------- show page layout. don't use in a real document! \usepackage{showframe} \renewcommand\...


2

You need to set the inner sep to zero to leave room for a full width image, as done in case 4 here. [inner sep = 0pt,xshift=.5*\mdfboundingboxwidth, yshift=.5*\mdfboundingboxheight, opacity=.4] %%%%%%%%%%%%%%%%


2

Here is a proposal that measures the widths of the expressions and allocates the minipage widths accordingly. \documentclass[a4paper]{report} \usepackage{mleftright} \usepackage{xfp} \usepackage{mathtools} \newcommand\SideBySideEquations[3][3em]{% \setbox0\hbox{$\displaystyle#2$}% \setbox1\hbox{$\displaystyle#3$}% \par\noindent \begin{minipage}[t]{\fpeval{(...


2

In the context you're using the “equalized boxes” you need a different definition. In particular you have to provide a unique label for the set of boxes to equalize. \documentclass[]{article} \usepackage{amsmath,amssymb} \usepackage{eqparbox} \newcommand{\eqmathsbox}[3][\mathord]{% % #1 = atom type, #2 = label, #3 = object #1{\eqmakebox[#2]{$\...


2

The problem here is {+\B} and using \B for negative values instead of the binary - operator. The braces around +B change its spacing as if you’d written \mathord{+\B}. Within the atom, -B is typeset like -2, with - as a unary operator and the same spacing on either side as B would have. That is, on the right, it happens by chance to be correct, but on the ...


1

You have to take into account that + or – are *binarysymbols, that require something on either side, so you just have to add an empty{}` on the left side to solve your problem: \documentclass{article} \usepackage{pgf} \usepackage{pgffor} \pgfmathsetseed{\number\pdfrandomseed} \newcommand{\InitVariables} { \pgfmathrandominteger{\A}{2}{10} \...


1

Given the complexity of the fraction expression, you may want to typeset it in display-style math mode instead of if inline or text-style math mode. In the following screenshot, the first row employs text-style math mode (as you do in the screenshot you posted), while the second row employs shows the same material in displaymath style. If a \frac ...


1

In Get rid of undesired vertical spacing within single footnotes (and footcites that are displayed at the bottom of the page) due to setspace settings we explicitly switched footnotes back to single-spacing regardless of what the global \setstretch might be. If you want \setstretch to apply to footnotes as well, remove the \def\baselinestretch {\setspace@...


1

please always provide complete, compilable small document with your table. Such document provide in its preamble information about your document's page layout, used relevant packages etc, which influence on your table design. for columns, where contents have only one line, I would rather use l and `r˛column types for more vertical spaces in cells I suggest ...


Only top voted, non community-wiki answers of a minimum length are eligible