44

Follow all the steps mentioned in the TeXnicCenter + Sumatra Tutorial, but keep in mind these few things: In the (La)TeX tab / (La)TeX compiler section / Command line arguments to pass to the compiler bar, you should write: -synctex=-1 -interaction=nonstopmode "%Wm" In the Viewer tab / Executable path section, what should be written is: "C:\Program Files\...


7

The Problem is, mentioned in the questions comment, that SumatraPDF is linked to the Latex-Compiler through synctex and doesnt know, which created the resulting PDF. You can use the inverse-search command through the a commandlineswitch of SumatraPDF:-inverse-search. The commands are: TeXnicCenter: -inverse-search "\"C:\Program Files\TeXnicCenter\TEXCNTR....


7

I'm not familiar with Notepad++, but I can tell you that you can pass the option -reuse-instance to SumatraPDF command line to achieve what you want. For more info see this page.


5

The shortcut F6 in TeXstudio is 'Compile', and F5 is 'Compile and view', or F1 prior to version 2.12.2. That is, if you press F5, TeXstudio will compile the TeX source file and then (if no error occurs) open the PDF viewer. If you want to open the generated PDF file automatically, use F5 rather than F6. In order to use SumatraPDF as the default PDF viewer, ...


5

One further point to consider is the the language of the OS you're using. As I had to learn two different names in links (C:\Programme\... vs C:\Program Files\... which point to the same directory for a German Win 7 OS and are mapped by the OS automatically) are two different directories for the DDE. While the forward search was working as intended, the ...


5

There's no WinEdt macro that acts on the file attributes. However we can tell WinEdt to use the attrib DOS command to achieve what you want. These are the steps you have to follow: Open the file %B\Exec\ExeCompilerPost.edt in WinEdt (%B is the directory where you've installed the program, something like C:\Program Files\WinEdt Team\WinEdt 10). Show the "...


4

I only have lyx 2.0.8 in Linux, without Sumatra nor Acroread, but I hope this guide help: Tools > Preferences ... >      Ouput > General > Foward search >          PDF command > SumatraPDF -reuse-instance $$o -forward-search $$t $$n      File handling > File ...


4

When, in Options -> Execution Modes -> PDF Viewer, you change the field "Synctex Switch" to --synctex=1, you also have to change the field "SyncTeX Filetype" to .synctex.gz otherwise WinEdt will consider the .synctex file instead of the right .synctex.gz for forward search. After doing that, simply recompile your file and forward search (Shift+F8 in WinEdt) ...


4

From texdoc latexmk, you can put the following in %HOME%/.latexmkrc if you want this set for anything run by your user, or in <project-dir>/.latexmkrc if you want this set on a per-project basis: $pdf_previewer = ’start "c:/Program Files/SumatraPDF (x86)/SumatraPDF.exe" %O %S’; Change the path as appropriate for your installation, of course. The path ...


4

In my case, I only had to go to Project -> Create with active file as main file when my main file was active, and everything now goes fine with SumatraPDF. Otherwise, if you already have an opened project, from the same menu execute Properties and indicate your main file.


4

The Problem: This is neiter an issue of TeXstudio nor of Sumatra PDF. Instead it's a result of the combination of Synctex and the build chain is rnw -> tex -> pdf. Synctex is originally designed to provide a connection between the tex file and the pdf. It does not know anything about the rnw. Towards a Solution: I'm not an R user and therefore have no ...


3

I have the same problem. In addition, I saw that lualatex does not produce a synctex.gz file. therefore, the forward search commando can not be executed. I was able to solve the problem, by changing the Option "Command line arguments to pass to the compiler" (On the tab (La)Tex of the profile) to -interaction=nonstopmode --synctex=1 "%Wm" especially, ...


3

This configuration works for me. Executable path C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\"" View project's output DDE command Command:"%bm.pdf" Server: SUMATRA Topic: control Forward Search DDE command Command:[ForwardSearch("%bm....


3

The solution is much simpler than what you've done so far: define a single command that runs latex, dvips and ps2pdf. In this way, when TeX-PDF-mode is active the PDF will be opened by your default PDF viewer without any further change. In your init file you can add something like this: (add-to-list 'TeX-command-list '("dvi2ps2pdf" "%(latex) %...


3

If you want both forward and inverse search in one command it can also be done. Options (in the menu bar) -> Configure TeXstudio ... -> Commands (tab on the left) Set "External PDF Viewer" to "C:/Program Files (x86)/SumatraPDF/SumatraPDF.exe" -reuse-instance -inverse-search "\"C:/Program Files (x86)/TeXstudio/texstudio.exe\" \"%%f\" -line %%l" -forward-...


3

Two be sure not to have the issue, whichever is the viewer, you can draw two dash lines side by side instead of one equal line. \documentclass{article} \usepackage{tikz-cd} \begin{document} With \texttt{equal} option there is the viewer issue: \[\begin{tikzcd}[sep=1.5em] 1\rar[phantom,"1"] &\circ\rar[equal] &\circ \end{tikzcd}\] With two \texttt{...


3

This answer comes a bit late, so I hope you have solved your problem with xelatex in the meantime. However, for the sake of completeness and to remove this question from the unanswered list, here is how you must proceed. The SumatraPDF command to initiate a forward search is -forward-search, so the right call to the WinEdt macro Run must be, in your case: ...


3

There's a LaTeXTools setting called keep_focus that you'll need to change to false to stop this from happening. You can access the settings by selecting Preferences > Package Settings > LaTeXTools > Settings – User.


3

AUCTeX's built-in support for SumatraPDF was improved with the release of version 11.90. So make sure you have the latest version installed, which can be easily done from ELPA. You need to touch three areas: Win10's PATH environment variable This step is optional: Adjust the PATH environment variable and add the directory containing SumatraPDF.exe to it. ...


3

It looks like you are using Sumatra to display your PDF file. You can rotate the displayed document in Menu > View > Rotate... or using Ctrl+Shift++/Ctrl+Shift+- hotkeys. Sumatra will then remember the document orientation across sessions and reloads. This would be totally plausible after taking a nap on your computer's keyboard and it would explain all your ...


2

You have an error in your command line. The \ after TeXnicCenter.exe has to be before ". So please correct the call for SumatraPDF to: C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\"" With the current versions of SumatraPDF (version 3.0) and ...


2

Your profile settings for "(La)TeX" are okay, but there are some missing configuration in the part "Viewer". Please see my configuration: In the first marked line with two red arrows you should have C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\"" Of course ...


1

Um yeah... so a full reboot of my computer seems to have fixed this issue. If it comes up again, I may try to report a bug to the TeXnicCenter team.


1

It's exactly what you said in the comment. If there's an error, the PDF won't be automatically opened. This is because errors almost always mean the PDF file wasn't changed, and often that it's completely blank. You can, however, use LaTeXTools view command C-l,v or C-l,j (which syncs to the corresponding line in the file) to open the PDF anyways.


1

Click on the top left icon which gives access to menus, and select Settings->Advanced Options. Notepad will open SumatraPDF-settings.txt: I tested: you can use negative values.


1

Although i can see this is quite old, I've been dealing with this issue for a couple of hours and just got around it. I too have gvim on windows with the vim-latex plugin having trouble with forward search. The main issue seems to be that the set shellslash isn't playing well with the forward search call to sumatra. I know this setting (shellslash) is ...


Only top voted, non community-wiki answers of a minimum length are eligible