Hot answers tagged

9

yes you are right. The new version of tkz-base is incompatible with the version of tkz-fct.sty. There was a small problem uploading the new file on CTAN. You will have to wait a while before you can find the package on CTAN. Currently you will find the file v1.2 here I think \tkzActivOff is no longer necessary with the latest version of TikZ. \...


8

It looks like it's due to the \foreach list having {0,1,...,x} and hence forcing 1 to be processed even if x is zero, instead of having {0,...,x} hence spining only once. And I guess there is a small typo with \i where it is i in the code. I'm not sure about the second point. EDIT: Indeed it's not a typo but a rather peculiar syntax. From fp readme file. ...


8

Both packages use \@xa with very different meanings. For the Tkz suite, \@xa stands for a coordinate, while thmtools wants it to mean \expandafter. In my opinion both are wrong in their assumption: Tkz should use a private name with a prefix, while thmtools should use \@xp like amsmath or have a prefix itself. By changing all appearances of \@xa in the Tkz ...


6

Note that tkz-fct doesn't do the calculations itself, they are performed by Gnuplot (I think). Therefore, you need to allow for execution of external programs by compiling with the --shell-escape flag, i.e. pdflatex -shell-escape filename.tex There will be a warning in the log related to this, saying something like Package pgf Warning: Plot data file `...


5

Here the code with only tkz-fct. It's possible to use only tikz or the excellent pgfplots. Some strange problems appears with gnuplot, it's why you can see sometimes (-5) instead of -5 or (-1)*(x-1)**2 instead of -1(x-1)**2. \documentclass{article} \usepackage{tkz-fct} \usetikzlibrary{arrows} \begin{document} \begin{tikzpicture}[scale=0.5,font=\...


3

You could use a scope environment \documentclass{standalone} \usepackage{tkz-fct} \begin{document} \begin{tikzpicture}[scale=.6] \tkzInit[xmin=-3,xmax=5.5, ymin=-3, ymax=6] \tkzAxeXY \tkzDefPoints{2/5/A, 2/3/B, 5/-2/C} \begin{scope} \tkzFct[domain=-1:2,thick]{x**2+1} \end{scope} \tkzDrawPoints[fill=white, size=4mm](A) \...


3

\documentclass[10pt,a4paper]{article} \usepackage{tkz-fct} \begin{document} \begin{tikzpicture} \tkzInit[xmin=-4,xmax=4,ymax=1] \tkzDrawX[label={},noticks] \tkzFct[domain=-2:2]{exp(-x**2)} \tkzDrawArea[color=blue, domain = -0.5:1] \end{tikzpicture} \end{document} The problem appears with pgf 3.0. The result is correct with pgf 2.1. I ...


3

Looks like a parsing issue for me ... It compiles without an error after I've applied surrounding brackets () to the equations. Maybe thats required by gnuplot, but I'm not sure. \documentclass{article} \usepackage{tkz-fct} \begin{document} \begin{tikzpicture} \tkzInit[xmin=-6,xmax=4,ymin=-6,ymax=4] \tkzGrid[color=gray!40,line width=0.2pt] \tkzDrawX[color=...


2

The tkz-fct package uses \alph for making internal labels, but this fails when babel-greek is loaded, because \alph (actually the internal version \@alph) is redefined to produce Greek letters. This should be considered a bug in tkz-fct, but there is a workaround, albeit a bit ugly. \documentclass[a4paper,11pt]{article} \usepackage[T1]{fontenc} \usepackage[...


2

I agree that the manual says that this should work and I agree that it doesn't... If you instead use: \tkzfctset{tan style/.style={dashed,>=,blue}} Then you get what you want.


2

I believe the following should do the trick. There might be a better approach, but what I've done here is just copied the code for the two Riemann commands you used and tweaked them. % arara: pdflatex % arara: pdflatex % arara: open \documentclass{article} \usepackage{tkz-fct} \makeatletter \def\aeDrawRiemannSumSupInfDiff{\pgfutil@ifnextchar[{% ...


2

A \clip will affect everything after it, to limit its effect place it in a scope environment along with the things that should be clipped. In this case the filling will partially cover the plotted lines, to fix that simply move the \tkzFct lines to the end of the diagram. \documentclass{standalone} \usepackage{tikz} \usepackage{tkz-fct} \begin{document} \...


2

You can put the \tkzGrid call in a scope with the desired properties: \begin{tikzpicture} \tkzInit[xmax=4, ymax=2] \begin{scope}[dashed] \tkzGrid \end{scope} \end{tikzpicture}


2

OK, I was missing two things: I had to install GNUPlot (sudo apt-get install gnuplot) And enable write18 with --shell-escape


2

tkz-fct is part of texlive and miktex so you should have it anyway or can easily install it via tlmgr or the miktex equivalent. It includes an 89 page manual that is full of examples (although the text is in french). In texlive you can view that via texdoc tkz-fct or see the pdf on the web at http://texdoc.net/texmf-dist/doc/latex/tkz-fct/tkz-fct-screen....


2

If you are happy with pgfplots instead of tkz-fct, then this would be a starting point: \documentclass[border=5mm]{standalone} \usepackage{pgfplots} \begin{document} \begin{tikzpicture} \begin{axis}[ samples=100, ticks=none, xmin = 0, xmax = 2, ymin = 0, ymax = 4, domain=0:1.6, axis x line=bottom, axis y line=left, ...


1

tkz-fct is a tool for the french students. pgfplots is a very fine tool for university and scientists. You can't ask too much of the first tool. It wants to keep it simple. \documentclass{standalone} \usepackage{tkz-fct} \begin{document} \begin{tikzpicture}[xscale=2,yscale=1.5,cap=round] \tkzInit[xmin=-1.5,xmax=1.5,xstep=0.5,ymax=0.0001,ystep=0.00001] \...


1

tkz-fct is far less sophisticated than pgfplots. You have to deal with the discontinuities on your own. \documentclass{article} \usepackage{tkz-fct} \begin{document} \begin{tikzpicture} \tkzInit[xmin=-6,xmax=6,ymin=-10,ymax=10,xstep=2,ystep=2] \tkzAxeXY \tkzFct[color=red,samples=400,domain=(-6):(-3)]{(-1*x**2)/(x+1)**2 -2} \tkzFct[color=red,...


1

I'm not that familiar with tkz-fct, but if using pgfplots instead is an option, you can try the following. The key point is the restrict y to domain key, which enables you to discard all computed values outside a certain domain. \documentclass[twoside]{report} \usepackage[a4paper, left=1.5cm, right=1.5cm]{geometry} \usepackage[T1]{fontenc} \usepackage[utf8]{...


1

The code posted in the linked answer works in texlive 2018 You get the warning Package pgf Warning: Plot data file `bb007.tkzfct.table' not found. on input li ne 9. if you do not use --shell-escape (or presumably if gnuplot can not be found in the path) Look for gnuplot in the log file, if the problem is --shell-escape then the log will show runsystem(...


1

You have to load the package mathrsfs for this. When compiling your code, I got some other message than you. Please check again. The problem for me was that \mathscr was not defined. % arara: pdflatex \documentclass[10pt,a4paper]{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[left=1.5cm,right=1.5cm,top=2cm,bottom=2cm]{geometry} \...


1

You need to do the graduations by yourself. \tkzDrawAxe draws the axe then you can add the graduation without the symbol and you can put the symbol at the end of the axe with the label. Another possibility is to rewrite the command \tkzLabelX but this macro is long. perhaps you can in this case write your own macro. I think it's perhaps the best solution.


1

The problem seems to be the tikzpicture inside an argument. It works if you use a lrbox environment instead the \savebox command. \documentclass[a4paper,10pt]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[frenchb]{babel} \usepackage{tkz-fct}% loads graphicx, xcolor \begin{document} Test : \newsavebox\imgA \begin{lrbox}{\imgA} ...


1

Once you fix the MWE [missing a package 'mathrsfs' and a opening document], it works just fine on XeLaTeX on Ubuntu... So anything else to your issue? \documentclass[10pt,a4paper]{article} \usepackage{tikz,tkz-tab,tkz-fct,mathrsfs} \begin{document} \begin{tikzpicture}[scale=1.3] \tkzInit[xmin=-1,xmax=4,ymin=0,ymax=5] \tkzGrid \tkzAxeXY \tkzFct[...


Only top voted, non community-wiki answers of a minimum length are eligible