What's the deal with Deno? We talk with a major contributor to find out. Listen now.

New answers tagged

1

A good workaround for what is happening is to define a command which resets the label of a figure. Afterwards, employ \AfterEndEnvironment (from etoolbox) to execute such command after every figure and figure* environment. This way, you might be able to redefine how caption should look like but also still get the original definition of figures caption after ...


0

The problem is solved by using the float option of tcolorbox: \newtcolorbox[use counter = myBox, number within = chapter]{myBox}[2][]{% boxrule = 0.5pt, breakable, colback = gray!5, colbacktitle = gray!10, coltitle = black, floatplacement = t, float, fonttitle = \sffamily, label type = myBox, sharp corners = all, title = Box~\thetcbcounter\secsp\textcolor{...


2

The quotation from the geometry manual says "If textwidth and width are specified at the same time, textwidth takes priority over width". In the source for tufte-book, specifically the file tufte-common.def, the following code is present: \RequirePackage[letterpaper,left=1in,top=1in,headsep=2\baselineskip,textwidth=26pc,marginparsep=2pc,...


2

Here's a bit of a stupid hack that may have a lot of bugs, but it seems to work for short paragraphs away from page breaks. \documentclass{tufte-handout} \usepackage{tcolorbox} \usepackage{blindtext} \usepackage{environ} \makeatletter \NewEnviron{grayground}{% \noindent\smash{\begin{tcolorbox}[colback=gray!20, colframe=gray!20, oversize, top=0pt, ...


1

You can use AtEveryCitekey to remove fields that you do not want from the side citations. For example: \AtEveryCitekey{% \clearfield{url}% \clearfield{address}% \clearfield{issn}% \clearfield{doi}% } To make citations shorter, it's easier to change the citestyle option of biblatex. \documentclass[nobib]{tufte-book} % no bib \usepackage[ style=...


1

I had the bright idea of reserving blank space in the margin using \marginpar. However, wrapfigure will still overlap any pre-existing margin material. I don't know of any way to delay the start of wrapfigure until the margin is empty (except manually). Also, I don't know why \wrapfigure works and \begin{wrapfigure} doesn't, but it probably has something ...


0

This bug is described here. The proposed workaround is to add these to the preamble, after fontspec has been loaded: % Set up the spacing using fontspec features \renewcommand\allcapsspacing[1]{{\addfontfeature{LetterSpace=15}#1}} \renewcommand\smallcapsspacing[1]{{\addfontfeature{LetterSpace=10}#1}}


Top 50 recent answers are included