Hot answers tagged

15

As well as changing fixed strings like chapter into the specified language, babel will enable the correct hyphenation patterns for the language. \documentclass[a4paper,12pt]{report} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[turkish]{babel} \begin{document} \chapter{Giriş} \end{document}


11

Load the font with the Language=Turkish option: \documentclass[11pt]{memoir} \usepackage{fontspec} \usepackage{polyglossia} \setdefaultlanguage{turkish} \setmainfont{Linux Libertine O}[ Language=Turkish, BoldFont=* Semibold, BoldItalicFont=* Semibold Italic, ] \setlength{\textheight}{2cm} \begin{document} In Turkish, `\textsc{ı}' and `\textsc{i}' ...


9

I don't think it should be be needed but you can re-assert turkish in the footnote: \documentclass[11pt]{memoir} \usepackage{fontspec} \usepackage{polyglossia} \setdefaultlanguage{turkish} \usepackage[semibold]{libertine} \begin{document} In Turkish, `\textsc{ı}' and `\textsc{i}' are different letters. {\footnotesize In Turkish, `\textsc{ı}' and `\...


8

The default computer modern doesn't have these glyphs. Add \usepackage{lmodern} or cm-super to your preamble, or install cm-unicode.


8

There is existing switch to change the output of i with the \WORD etc. commands but you overload the default settings for the uppercase character. The same problem you have exists also for the german double s which produce SS when you use \WORD but the module s-lingual-de.mkiv shows how you can change this. With the command \overloaduppercase you can set ...


7

You can perhaps implement the proposed postfix syntax with LuaTeX. With either XeLaTeX or LuaLaTeX, the following prefix syntax works: \documentclass{article} \usepackage{xparse} \usepackage{fontspec} \ExplSyntaxOn \NewDocumentCommand{\trgen}{m} { #1' \kutt_trgen:n { #1 } } \prg_generate_conditional_variant:Nnn \tl_if_in:nn { ne } { T,F,TF } \...


5

babel has a new interface to setup language dependant fonts. It seems to handle this correctly: \documentclass[11pt]{memoir} \usepackage[english,turkish]{babel} \babelfont[english]{rm}[Language=Default]{Linux Libertine O} \babelfont[turkish]{rm}[Language=Turkish]{Linux Libertine O} \begin{document} In Turkish, `\textsc{ı}' and `\textsc{i}' are ...


5

If I try the “proper” way, that is, making the apostrophe a letter as far as hyphenation is concerned, I get İs-tan-bu-l-’-lu-la-rın-ki because the patterns allow hyphens at either side of a consonant except for some specific combinations, which don't take the apostrophe into consideration. Perhaps you would consider making a feature request at the TeX-...


4

I suggest you add the instructions \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} to your preamble. The following example had to modify the color coding choices since you didn't provide information about how the various java... colors are defined. \documentclass{article} \usepackage[utf8]{inputenc} % assumes input is utf8-encoded \usepackage[T1]{...


4

It is imho not a good idea to redefine such accent commands. But in your case you can make \turc robust: \documentclass{scrartcl} \usepackage{natbib} \let\turc\c \usepackage{etoolbox} \robustify\turc \renewcommand{\c}{\ensuremath{c^\pi}} \begin{document} \citep{ABC} \bibliographystyle{plainnat} \bibliography{lit} \end{document}


2

When you do \let\turc\c you are essentially defining \def\turc{\OT1-cmd \c \OT1\c} Note that \OT1-cmd is a single control sequence, as well as \OT1\c; they can't ordinarily be written or used without special tricks. Simplifying a bit, the purpose of \OT1-cmd is twofold: during normal typesetting, it ignores the following \c token and uses \OT1\c, which ...


2

I think this is a bug in hyperref, as ğ prints correctly. A horrible kludge to solve it is to use @UNPUBLISHED{ldk, author={{Ubuntu Community}}, title={Linux da\u{g}{\i}t{\i}mlar{\i} k{\i}lavuzu}, note={URL: \url{http://wiki.ubuntu-tr.net/index.php?title=Linux_da%C4%9F%C4%B1t%C4%B1mlar%C4%B1_k%C4%B1lavuzu}}, month={Accessed: 6 October}, year={...


2

I succeeded by passing the title directly to \printbibliography: \begin{filecontents*}{\jobname.bib} @article{abc, author={A. Uthor}, title={Title}, journal={Journal}, year=2018, } \end{filecontents*} \documentclass[a4paper,11pt]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[turkish,shorthands=:!]{babel} \usepackage{...


2

Your MWE can be further reduced to the following code: \documentclass[11pt]{article} \usepackage{pdfpages} \usepackage[turkish]{babel} \begin{document} \section{B} \includepdf[pages=-]{<document name>} \end{document} That still produces the error message Missing \endcsname inserted.. As already discussed here, and here the turkish option of babel ...


2

You can pass the unicode option to hyperref and the warnings will disappear. \documentclass[hyperref=unicode]{beamer} \usepackage[utf8]{inputenc} \usepackage[turkish]{babel} \title{Title} \author{İÖÇığş} \institute{University} \date{2020} \begin{document} \frame{\titlepage} \begin{frame} \frametitle{Sample frame title} Turkish Pangram: Pijamalı hasta ...


2

turkish makes the : an active char (a shorthand) and tikz doesn't like this. You can either disable the short hand or try the babel library of tikz. \documentclass{beamer} \usepackage{beamerthemeshadow} \usepackage[turkish]{babel} %Türkçe bölüm isimleri \usepackage[utf8]{inputenc} %Türkçe karakterler \usepackage[T1]{fontenc} %Türkçe heceleme %\shorthandoff{:...


1

Welcome to TeX.SE! Your babel overwrite meaning of some internals of tcolorbox, in your case particulary =. This can be restored with adding \shorthandoff{=} to your document body: \documentclass{article} \usepackage[turkish]{babel} \usepackage[most]{tcolorbox} \begin{document} \shorthandoff{=} \begin{tcolorbox}[title = My heading line] This is a \...


1

The acronym package uses a colon in its internal labels and this conficts with the active colon set up by babel-turkish. There's nothing special about the colon, so we can change it into something else, possibly unique. I chose @@@@. \documentclass[12pt]{book} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} % also latin5 \usepackage[turkish,shorthands=:...


1

Ensure your file is saved as UTF-8 and add \usepackage[utf8]{inputenc}, not latin1. I also simplified the list of packages, removing duplicates and those that are already loaded by beamer. \documentclass{beamer} \usetheme{Warsaw} \usefonttheme{professionalfonts} \usepackage{mathptmx} \usepackage[scaled=.92]{helvet} \mode<presentation> \usepackage[...


Only top voted, non community-wiki answers of a minimum length are eligible