Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Hot answers tagged

181

Sorry to reactivate this old post but there was no correct answer. The message : (running on Debian, switching to user mode!) cannot setup TLPDB in /home/USER/texmf at /usr/bin/tlmgr line 5308. is generated when tlmgr was not initialized. In most cases, launching the following command (as a normal user) solves the problem : $ tlmgr init-usertree ...


103

In my texlive installation (in ubuntu 15.04), I tried installing framed.sty latex package with the following command: $ tlmgr install framed I got this error message: (running on Debian, switching to user mode!) cannot setup TLPDB in /home/myusername/texmf at /usr/bin/tlmgr line 5435. I took the following steps: $ cd ~ $ mkdir texmf $ tlmgr init-...


99

Try the following commands, one after another. If you progress, respective folders may already be deleted: sudo apt-get purge texlive* sudo rm -rf /usr/local/texlive/* and rm -rf ~/.texlive* sudo rm -rf /usr/local/share/texmf sudo rm -rf /var/lib/texmf sudo rm -rf /etc/texmf sudo apt-get remove tex-common --purge rm -rf ~/.texlive find -L /usr/local/bin/ -...


69

Ubuntu and Debian ship with a totally outdated TeXLive 2009. The current version is 2011, released a couple of weeks ago. I highly recommend installing TeXLive using its own installer instead as described in How to install “vanilla” TeXLive on Debian or Ubuntu?. Then you can install packages using the normal tlmgr package manager: tlmgr install <package ...


55

You could use apt-cache: apt-cache search outlines returns for me libfont-freetype-perl - Read font files and render glyphs from Perl using FreeType2 ... texlive-latex-extra - TeX Live: ergänzende Pakete für LaTeX You can see texlive-latex-extra here (even though it's not installed on my system, as dpkg -l | grep texlive shows - I installed TeX 2011 from ...


49

A lot of frequently used *TeX packages have been combined into Ubuntu packages. In this case a quick search in the Ubuntu Package Manager shows that xlop is part of the texlive-generic-extra package, which you can install using apt-get install or the GUI as preferred. Having said that, it's not particularly difficult to install *TeX packages manually once ...


45

You probably have not installed the full TeX Live but only a decent selection of it. To get the package you are after you can either install the full distribution, or just install the package texlive-science which contains algorithm2e (the same package also contains algorithmicx). To install the latter you can issue the following in a terminal: sudo apt-...


44

So, what doesn't work is tlmgr install xzdec Why would it? tlmgr is not working yet. So, as I'm writing the question, I realize I might try sudo apt-get install xzdec and it worked! What .tex document would once not compile, now does! (Well anyways, I next tried sudo tlmgr install parskip, and then the TeX document compiled, but I'm hoping that on-the-...


37

First suggestion would be, Check if the caption.sty file is somewhere on the system $ locate caption.sty If it is not installed, most probably the package is not on the basic configuration of texlive. I used the command $ apt-cache search caption | grep tex and found the following packages texlive-latex-recommended - TeX Live: LaTeX recommended ...


31

elsarticle is not included in texlive-latex-extra http://packages.ubuntu.com/trusty/all/texlive-latex-extra/filelist, but in texlive-publishers packages http://packages.ubuntu.com/trusty/all/texlive-publishers/filelist. So, you need to install it first. Run this command on terminal sudo apt-get install texlive-publishers and then try compile your document ...


28

Have you tried this in a terminal? $ sudo apt-cache search texlive french texlive-doc-fr - TeX Live: French documentation texlive-lang-french - TeX Live: French $sudo apt-get install texlive-lang-french This example should work in a well installed TeX Live: \documentclass[french,11pt]{article} \usepackage{babel} \usepackage[utf8]{inputenc} \begin{...


24

Install texlive-fonts-recommended: sudo apt-get install texlive-fonts-recommended


24

As you tested, this solves the problem. sudo apt-get install texlive-fonts-recommended sudo apt-get install texlive-fonts-extra Some expert could say if both packages are necessary or only one does the job.


21

Martin Betz's answer is great but it is missing one line that caused issue on my machine (Ubuntu 13.04). This was for upgrading from 2012 to 2013. After 5., run sudo apt-get remove tex-common --purge. If not, you may have the problem I faced here Does TeXLive2013 need any special install instructions?


20

Another solution is to download TeX Live 2011 from here. After having installed it, and having performed the post-installation step, you can then use tlmgr to list the packages that are available for download or have been updated as follows: sudo -i tlmgr update --list You can also use the following command, for example, to get all the packages available ...


20

As both Debian maintainer of TeX Live and author of tlmgr, I would like to state my personal ideas about it: First, with the Debian native packages of TeX Live there will be in foreseeable time no tlmgr available. Even if it will be available, then only for managing TEXMFHOME or TEXMFLOCAL (for the sysadmin) (by using the user mode patches for tlmgr which ...


20

You can find all locations that TeX will search for files using kpsepath tex The format is a bit weird: items are separated by colons, directories that should be searched using a ls-R index file start with !!, directories to be searched recursively end with //. To clean it up, we can process the output a bit: kpsepath tex | tr ':' '\n' | perl -ne 'm-^(!!)...


18

I combined some of the links mentioned here, you will find the links in the source comments. This code supports: Forward search (Emacs to Evince, via C-c C-v) Backward/Inverse search (Evince to Emacs, via C-Mouse-1, that is Ctrl + "Left Click" in Evince) Path names with spaces Multifile setups (TeX files requested by Evince will be opened if they aren't ...


18

The easiest way in ubuntu is to use the ubuntu package manager (from the desktop) and install the texlive package. As an editor you can choose whatever you want (texmaker, texstudio or any editor like gedit, vim and so on). Alternatively, you can use the terminal to install the packages, using sudo apt-get install texlive texstudio Dependencies usually ...


17

You can install the Package texlive-latex-extra. That should resolve the problem. This seems to be a bug in Ubuntu which does not pull in this packet when installing Kile.


17

Some benefits (in no particular order) assuming we are speaking of the Ubuntu official repositories are: More uptodate packages. As of today, several months after the release of TexLive 2014 ubuntu 14.04 still has TexLive 2013 or PGF 2.10 in the official repos. More control over the system. Even if you only need the e.g. tcolorbox ctan-package you have to ...


16

You have to install texlive-fontsextra. That should work. EDIT: texlive-fonts-extra In Ubuntu, install it using sudo apt-get install texlive-fonts-extra


15

You should get an updated version of TexLive - which you obviously did not do before. The latest version includes Source Sans Pro. It is however not in the official repository for 12.04 and 12.10, so you have to add an unofficial one: $ sudo add-apt-repository ppa:texlive-backports/ppa After that, you can install TexLive with apt, not forgetting to get ...


15

Under Ubuntu, fullpage.sty is in the package texlive-latex-extra. You can install it with sudo apt-get install texlive-latex-extra Since the documentation is very big (327 MB), I installed it with sudo apt-get install texlive-latex-extra --no-install-recommends


15

You can create the gaps in the ring by drawing lines in the background color. In a similar manner, the circles on the outside can be drawn: \documentclass{article} \usepackage{tikz} \begin{document} \begin{tikzpicture}[baseline=0] \draw[black, line width=2mm] (0, 0) circle (1.1); \draw[white, line width=2mm, overlay] \foreach \a in {0, 120, 240} { ...


14

What are you using? (Linux, Windows, Mac) If you're using Linux, then Okular's probably the easiest PDF viewer to set-up synctex forward/backward search with emacs. Once you've installed Okular, you can add the following code to your .emacs config file: ;; Okular (setq TeX-view-program-list '(("Okular" "okular --unique %u"))) (add-hook 'LaTeX-mode-hook ...


14

Go to Tools > Preferences > File Handling > File Formats. Choose the file format. I am guessing that you want PDF (pdflatex). Change "viewer" to "evince". You are done. The reason it all of a sudden started using Okular is because you installed Okular after you installed LyX and you did Tools > Reconfigure (or you did something that triggered that). Why ...


13

In Ubuntu minted is included in texlive-latex-extra package sudo apt-get install texlive-latex-extra Or you can install minted manually, as mentioned in the comments. Best way to install packages for TeXLive in Ubuntu? Once you have minted installed (which comes by default with TeXLive), you'll need python-pygments sudo apt-get install python-pygments ...


13

Make sure that you have latex-xcolor installed. I think texlive-latex-extra may contain titlesec Btw. the ubuntu texlive is pretty old. Maybe you want to install it manually.


Only top voted, non community-wiki answers of a minimum length are eligible