29

This looks like the basic question but it seems like the hardest thing to me.

I need to set the whole document's font style as follows :

Font Family: Times New Roman or GoudyOlSt BT

Font Size: 11pt

I am doing something like below but have no effect at all :

\fontencoding{T1}
\fontfamily{garamond}
\fontseries{m}
\fontshape{it}
\fontsize{11}{14}
\selectfont

Also, that would be nice to see the available font-family styles if possible.

I would really appreciate if someone direct me to right way.

1
  • 2
    Times Roman fonts are supported by mathptmx, which you can specify together with an 11pt document class option.
    – Werner
    Commented Nov 4, 2011 at 20:10

2 Answers 2

22

Fonts

You could use TeX Gyre Termes, Times or txfonts. They are similar to Times New Roman (if you want to look at other fonts you should hunt for a similar serif font, see e.g. http://www.tug.dk/FontCatalogue/seriffonts.html). Fonts are loaded and activated for a document by loading the package for the font via \usepackage. You probably want to use them with T1 encoding and to do this you should use \usepackage[T1]{fontenc} (see Why should I use \usepackage[T1]{fontenc}?).

So, for TeX Gyre Termes you'd use:

\usepackage[T1]{fontenc}
\usepackage{tgtermes}

For Times:

\usepackage[T1]{fontenc}
\usepackage{mathptmx}

For txfonts:

\usepackage[T1]{fontenc}
\usepackage{txfonts}

Font size

To get 11pt font size simply add 11pt as an option to \documentclass, so if you're using the article document class you'd use \documentclass[11pt]{article}.

Example

The following is an example to illustrate one font. I use the package lipsum to get example text.

\usepackage[T1]{fontenc}
\documentclass[11pt]{article}

\usepackage{tgtermes}
\usepackage{lipsum}

\begin{document}

\lipsum

\end{document}

Outpus

3
  • thanks a lot for your response. that works pretty well but I am having another type of problem right now. When I set the font-size to 11pt, some of my figures aren't the place where they are supposed to be. maybe this is another question but I thought it might be a common porblem
    – tugberk
    Commented Nov 4, 2011 at 20:15
  • 3
    @tugberk: This is another question. ;-)
    – lockstep
    Commented Nov 4, 2011 at 20:23
  • @lockstep , with \usepackage{opensans} Captions do not have the new font... Commented Jul 11 at 23:27
0

I wanted to use the san serif font LMSS under the lmodern family. Just like the above post mentions, you have to use the right packages:

\usepackage[T1]{fontenc}
\usepackage{lmodern} % Font Family

It was essential (at least for me) to specify the following:

\renewcommand{\rmdefault}{lmss}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .